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AES67 CONFIGURATION 
AES67 is a technical standard designed to allow audio over IP and audio over Ethernet 
interoperability between different networking systems. All Powersoft amplifiers featuring a 
Dante card can be configured to work with AES67 audio streams.  
 
Powersoft amplifiers support a limited number of audio streams, also known as ‘flows’ – the 
actual number varies by device according to the Dante card it utilises. In general, ‘Dante Ultimo’ 
cards allow for a maximum of 2 transmit flows and 2 receive flows to be created, while amplifiers 
with ‘Dante Brooklyn II’ cards can simultaneously stream 32 x 32 flows. 
 
Table 1 below presents a summary of all Dante enabled Powersoft amplifiers and their flow 
streaming capabilities. 
 

 Ultimo UXT  
(2 x 2 flows) 

Ultimo UXT 
(2 x 0 flows) 

Ultimo ULT 
(2 x 0 flows) 

Brooklyn II 
(32 x 32 flows)  

Ottocanali DSP+D     ✓ 

Quattrocanali DSP+D 1  ✓ ✓  

Duecanali DSP+D1  ✓ ✓  

X Series    ✓ 

T Series2 ✓    

Mezzo AD ✓    
Table 1 – List of Dante-enabled Powersoft amplifiers. 

 
NOTE 1: Quattrocanali DSP+D and Duecanali DSP+D amplifiers cannot transmit Dante flows. 
 
NOTE 2: Four-channel versions of T Series amplifiers can be configured to have channels as  either 4-IN/4-OUT at 
48 kHz or 4-IN/0-OUT at 96kHz. Selection can be done in ArmoníaPlus, in the amplifier’s internal configurations, 
under Options > Dante Settings > Device Configuration.  
 
The Dante modules in Powersoft amplifiers operate with their own dedicated firmware. To 
ensure a correct configuration of AES67, it is recommended that all modules are running the 
latest Dante firmware. 
 
The following firmware versions are recommended for Dante cards in Powersoft amplifiers: 

• Brooklyn II – version 2.0.1.0 or above;  
• Ultimo UXT (T Series) – version 2.1.3.0 or above; 
• Ultimo UXT (Quattrocanali and Duecanali Series) – version 4.1.1.4 or above; 
• Ultimo ULT– version 3.10.4.1 or above. 

 
More information on how to update the Dante firmware in Powersoft amplifiers can be found on 
Powersoft’s website. 

https://armonia.powersoft.it/firmware-updating/
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Enabling AES67 and Receiving Flows 
Before setting up an AES67 connection between an amplifier and a third-party device, it is 
necessary to enable AES67 streaming on the amplifier. This is done via the software application 
’Dante Controller’ provided by Audinate. Free download versions of the software are available 
for ‘Windows’ and ‘Mac OS X’ directly on Audinate’s website. 
 
When opening ‘Dante Controller’, all devices connected to the Dante network will be displayed 
in the list of transmitters and receivers. 
 
To enable AES67 streaming: 
 

1. Open the Device View window by double-clicking on the device to be configured. 
2. Select the AES67 Config tab1 (Figure 1). 
3. Under ‘AES67 Mode’ select ‘Enabled’ from the drop-down list. 

 

 
Figure 1 – Dante Controller AES67 Config tab in the Device View window. 

 
NOTE 1: If the AES67 Config tab is not showing in the amplifier’s device view, the most likely solution for this issue is 
to update the firmware of the Dante card. More information can be found on Powersoft’s website. 
  
It is important to note that this operation requires a device reboot. This can be done by simply 
clicking ‘Reboot’ under ‘Reset Device’. However, in some instances, it has been verified that a 
manual reboot of the amplifier is necessary for modifications to take effect and is, therefore, 
recommended as best practice.  
 
The above operation will automatically enable the amplifier to receive AES67 streams, and in 
most circumstances, this is the only necessary configuration.  However, some amplifiers can also 
be set to transmit AES67 audio streams over the Dante network. 

https://www.audinate.com/products/software/dante-controller
https://armonia.powersoft.it/firmware-updating/
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Transmitting AES67 Flows 
Although enabling AES67 in the ‘Dante Controller’ automatically configures the amplifier to 
receive AES67 streams, an additional step is necessary if transmitting audio streams is desired.  
 
In Dante, there are two types of audio streams, or ‘flows’: Unicast and Multicast. Unicast flows 
are one-to-one routes that deliver audio to and from specific devices, and support 4 channels 
of audio simultaneously. A multicast flow “broadcasts” the audio so that multiple receivers can 
subscribe to it, but the transmitting device is only using one of its available flows. It allows up to 
8 audio channels to be streamed in one flow. 
 
When connecting two devices in Dante Controller, a unicast transmit flow is automatically 
created by default from the transmitter to the receiver. However, AES67 connections only utilise 
multicast flows, as this is a universal communication method used by most network systems. 
Therefore, it is necessary to create a multicast flow for the channels of the AES67 transmitting 
device.    
 
To create a multicast Dante flow and enable AES67 streaming from a transmitting device: 
 

1. Open the Device View window by double-clicking on the transmitting device to be 
configured. 

2. Click on the ‘Create a new multicast’ button at the top bar. 
3. In the ‘Create Multicast Flow’ window, tick the box next to ‘AES67 Flow’ (Figure 2). 
4. Select the channels to be included in the multicast flow. 
5. Click ‘Create’. 

 

 
Figure 2 – Dante Controller ‘AES67 Config’ tab in the ‘Device View’ window. 

 
A list of all the transmit flows created for the device, including multicast AES67 flows, can be 
found in the Device View window, under the Transmit tab. 
 
Important note: Dante Controller gives the user the option to save all the routing information as 
a preset by clicking on the “Save preset” button. It is however strongly advised that the 
preset feature is not used, as loading saved presets in Dante Controller will erase all patching 
previously made with AES67 devices.  
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POWERSOFT AMPLIFIERS AND Q-SYS NETWORKING VIA AES67 
The following application notes are applicable to Q-SYS and Powersoft amplifiers connections 
via an AES67 network. Powersoft has also made a series of free plug-ins and communication 
protocols available for the control of amplifiers directly from the Q-SYS Designer platform. For 
more information and to access these tools, please email our technical support team at 
support.audio@powersoft.com.  
 
The integration of Powersoft amplifiers and a Q-SYS AES67 network is done via Dante Controller 
and the additional software application ‘Q-SYS Designer’, which can be downloaded directly 
from QSC’s website. 
 
Before creating any AES67 connections with Q-SYS, verify that the properties of Q-SYS Designer 
match those of Dante ‘Quality of Service’ (QoS) management. This is specially the case for 
networks running both AES67 and Dante streams.  
 
In Q-SYS Designer go to File > Design Properties (Figure 3). Under ‘QoS Preset’ select ‘Audinate’ 
from the drop-down menu. 
 

 
 

Figure 3 – List of streaming devices available in Q-SYS Designer. 
 
The operation above assumes that Dante streams are present in the network, therefore, any 
network switch in place must be configured to work with a Dante network, i.e. with the DSCP 
parameters shown in Figure 3. 
 
 If no Dante streams are present and only AES67 streams are used in the network, the switch 
may be configured following DSCP parameters suggested by QSC, and in such case, ‘QLAN’ 
should be the QoS preset selected. 
 
 

mailto:support.audio@powersoft.com
https://www.qsc.com/resources/software-and-firmware/q-sys-designer-software/
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AES67 from Q-SYS to Powersoft Amplifiers 
For this operation, the amplifier must first be configured in Dante Controller so that AES67 
streaming is enabled. This is done by following the steps described in the section ‘Enabling 
AES67 and Receiving Flows’ of this document. 
 
To set up a Q-SYS AES67 transmitter: 
 

1. Open Q-SYS Designer. 
2. In the Inventory pane, click the ‘+’ symbol to add a device.  
3. Select the option Streaming I/O and then AES67 Transmitter (Figure 4). 

 

 
Figure 4 – List of streaming devices available in Q-SYS Designer. 

 
4. An AES67 Transmitter device will be added to the Inventory list. Click, drag and drop this 

device as a component onto the design schematic window (Figure 5). 
 

 

Figure 5 – AES67 Transmitter device in Q-SYS Designer. 
 

5. Click on the AES67 Transmitter component to view its properties under the Properties 
Pane. Set ‘Connection Mode’ to ‘Auto’ and edit the ‘Channel Count’ to the number of 
channels to be transmitted from Q-SYS to the amplifier in the AES67 flow (Figure 6). It is 
important to note that it has been verified that changing the ‘Channel Count’, without 
deleting/redoing the patching in Dante Controller, creates audible HF distortion in the 
audio signal. 
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Figure 6 – AES67 Transmitter properties in Q-SYS Designer. 
 

6. Save the design to the Q-SYS Core by pressing F5 or selecting File > Save to Core  Run . 
7. Double-click the AES67 Transmitter component to open the Connection pane 

(Figure 7). 

 
 

 Figure 7 – AES67 Transmitter Connection pane. 
 

8. Note that the AES67 Transmitter automatically assigns a name to the ‘Stream Name’. The 
AES Transmitter device is now available for connection with other AES67 devices and can 
be seen in the list of Dante Transmitters in Dante Controller (Figure 8). 
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Figure 8 – The AES67 Transmitter in Dante Controller. 
 

9. Note from ‘Figure 7’ that Q-SYS has automatically assigned an IP address to the AES67 
Transmitter flow (239.69.xxx.xxx). This default configuration is appropriate when only 
one AES67 Transmitter component is used in the Q-SYS design schematic. However, 
when several transmitter components are added to the design, Q-SYS will incorrectly 
assign the same IP address to all AES67 flows. In such instance, it is recommended to 
manually configure the IP of the ‘Multicast Address’ in each transmitter component 
independently (Figure 9). 
 

  
 

Figure 9 – Manual configuration of the ‘Multicast Address’ for an AES67 Transmitter. 
 

For best practice, it is recommended that static multicast IP addresses are always used for Q-SYS 
AES67 Transmitter flows, as it will make the network routing more reliable. This is specially the 
case when devices are restarted and/or put in a different network, causing the IP addresses to 
change and the routing to be lost. 
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AES67 from Powersoft Amplifiers to Q-SYS 
For this operation, a multicast AES67 flow must have been created for the amplifier in Dante 
Controller. This is done by following the steps described in the section ‘Transmitting AES67 
Flows’ of this document. 
 
To set up a Q-SYS AES67 receiver: 
 

1. Open Q-SYS Designer. 
2. In the Inventory pane, click the ‘+’ symbol to add a device.  
3. Select the option Streaming I/O and then AES67 Receiver (Figure 10). 

 

 
Figure 10 – List of streaming devices available in Q-SYS Designer. 

 
4. An AES67 Receiver device will be added to the Inventory list. Click, drag and drop this 

device as a component onto the design schematic window (Figure 11). 
 

 

Figure 11 – AES67 Receiver device in Q-SYS Designer. 
 

5. Click on the AES67 Receiver component to view its properties under the Properties 
Pane. Edit the ‘Channel Count’ to match the number of channels to be received from the 
amplifier in its AES67 multicast flow (Figure 12). For this example, four channels have 
been selected to match the number of channels seen in ‘Figure 2’. 
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6. Set ‘Connection Mode’ to ‘Auto’. 
 

 
 

Figure 12 – AES67 Receiver properties in Q-SYS Designer. 
 

7. Save the design to the Q-SYS Core by pressing F5 or selecting File > Save to Core  Run . 
8. Double-click the AES67 Receiver component to open the Connection pane (Figure 13). 
9. Note that the AES67 Receiver status initially displays the message “Not Present – Waiting 

for SAP”. This means that the receiver is waiting for its first SAP announcement from the 
network. 
 

 
 

 Figure 13 – AES67 Receiver Connection pane. 
 

10. The status of the receiver should automatically change to “Not Present - No Stream 
Specified” (Figure 14), as soon as the AES67 Receiver receives its first SAP 
announcement. This indicates that the AES67 streams in the network have been 
discovered but have not yet been selected. Note that sometimes it may take up to 30 
seconds for the status to be updated.  
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Figure 14 – AES67 Receiver status following the first SAP announcement. 

 
 

11. In the Connection pane, click on the field next to ‘Stream Name’ and, from the drop-
down list, select the transmitting device to connect the receiver to. In this example, the 
same Ottocanali 12K4 D+DSP amplifier from ‘Figure 2’ has been selected (Figure 15). It is 
important to emphasise that the number of channels on both receiving and transmitting 
devices must be the same. 
 

 
Figure 15 – AES67 Receiver properties in Q-SYS Designer. 

The AES Receiver is now ready to receive AES67 flows from the Powersoft amplifier. 
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